Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input:
  4. 4. Sample Output:

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目大意:给两个数并求和,将求和结果按三个一组输出并用逗号分隔。

分析:将和用to_string转化为字符串,遍历输出字符串。如果下标 (i+1)%3 == length % 3且该字符不为最后一个字符,说明该字符后面需要加逗号。符号直接continue处理即可。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include<iostream>
using namespace std;
int main(){
int a,b,length;
string s;
cin >> a >> b;
s = to_string(a+b);
length = s.size();
for (int i=0;i<length;i++){
cout << s[i];
if (s[i] == '-') continue;
if ( (i+1)%3 == length%3 && i!= length-1) cout << ",";
}
return 0;
}
Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input:
  4. 4. Sample Output: